Electronics problem with my G450X - BMW G450X Riders Forum & Registry



Remove this advertisement by REGISTERING.

Results 1 to 6 of 6
  1. #1
    SLADRY's Avatar
    Points: 286, Level: 5

    Location
    PL
    Joined
    Nov 2020
    Online
    2 Weeks Ago
    Posts
    3 / 0 / 0 / 0
    Motorcycle
    '09 G450X
    Hi
    I have a problem with my G450X

    After the service and restart of the computer, the machine worked very well, but after a few trips for 4 hours, it starts to shoot from the exhaust and then, after driving a dozen or so kilometers, it stops and runs at low speed. After unscrewing the handle it chokes and goes out ...
    I decided to remove the second butterfly according to the instructions described here - it went smoothly ...
    However, after a dozen or so kilometers, quite uneven driving and shots from the silencer, it stopped and now I don't know what to do ...
    Is there any way to reset the ECU without tools?
    I was in Ukraine and I couldn't connect to a computer ...
    Maybe some of you have an idea?

    greetings
    Sladry
    I'm from Poland

  2. Remove Advertisements
    F800Riders.org
    Advertisements
     

  3. #2
    Tims1572's Avatar
    Points: 37,358, Level: 100

    Real Name
    Tim
    Location
    Arizona
    Joined
    Mar 2012
    Online
    2 Hours Ago
    Posts
    1,480 / 18 / 46 / 116
    Motorcycle
    '15 FE 501
    Motorcycle
    '77 Mc400
    Motorcycle
    '10 Road Glide
    Motorcycle
    '09 G450X
    Welcome Sladry from Poland..

    Sounds to me like you have a dirty injector. Or the fuel pump is on its way out. or the fuel tanks vent is being pinched from installing the ECU bracket over the top of it or the seat is squashing it. where it can't get air flow.

    If its the Fuel injector? You need to back flush it, an ultrasonic cleaner can help get it really clean but it should still be back flushed.
    Many motorcycle shops can do this or even some automotive repair facilities that do fuel injection service.

    Also when it does start misfiring, loosen the fuel tanks filler cap and listen for air flow rushing in. The check valve along the length of the vent hose that runs from the fitting behind the filler cap could be clogged. or the hose itself is pinched from the seat resting on it. The aluminum check valve should be about 10 inches back under the front of the seat along the left frame tube. It's a one way valve so you should only be able to blow through it in one direction.

    If everything checks out then Pull the fuel injection throttle body from the lower cylinder heads rubber flange and crank it over to take a look at the fuel spray pattern and then remove the fuel injector itself if it isn't fogging a smooth flow from the injector itself.
    If you just did the second butterfly removal you will have to repeat many of the same steps to get to it.

    Let us know what you find out.

  4. Thanks bello650 thanked for this post
    Likes bello650 liked this post
  5. #3
    SLADRY's Avatar
    Points: 286, Level: 5

    Location
    PL
    Joined
    Nov 2020
    Online
    2 Weeks Ago
    Posts
    3 / 0 / 0 / 0
    Motorcycle
    '09 G450X
    Thank you for the suggestion

    1. Fuel tank is vented properly - I checked
    2. The fuel pump is new ... and I suspect it is ok - I will attach the pressure gauge and check its pressure
    3. The injection was cleaned with an ultrasonic cleaner some time ago ... - I'll do it again

    The strangest thing is that a mechanic who has the ability to hook up a diagnostic tool and cannot read errors ... so puts him in an automatic calibration mode. After that, the machine starts working very well for a few trips and the situation repeats itself

    Can there be any sensor that gives bad readings and the computer cannot handle them?

  6. Remove Advertisements
    F800Riders.org
    Advertisements
     

  7. #4
    Tims1572's Avatar
    Points: 37,358, Level: 100

    Real Name
    Tim
    Location
    Arizona
    Joined
    Mar 2012
    Online
    2 Hours Ago
    Posts
    1,480 / 18 / 46 / 116
    Motorcycle
    '15 FE 501
    Motorcycle
    '77 Mc400
    Motorcycle
    '10 Road Glide
    Motorcycle
    '09 G450X
    Check the radiators temperature switch in the bottom right hand side of the radiator facing rearward. The one closest to the center of the bike out of the 2.
    There are 2 of them, the outer one is the temperature sensor for the coolant that operates the fan and you can see the wires going directly to the fan itself and the other towards the inside is the temperature switch that feeds information to the ECU for fuel control (rich or lean).
    It switches at approximate 180 Degrees fahrenheit as does the fans switch.
    It can be tested open or closed, with a multimeter. If this switch isn't functioning the ECUs fuel controller will get mixed signals and the engine will run intermittent and poorly.

  8. #5
    bello650's Avatar
    Points: 22,568, Level: 100

    Real Name
    Pascal
    Location
    Brussels / Belgium
    Joined
    Jun 2010
    Online
    2 Days Ago
    Posts
    414 / 10 / 38 / 21
    Motorcycle
    '08 G450X
    You can have a bad electrical connector, check if the pin inside is in the right place or bad conctat in the connector himself put some contact cleaner or a wire sometimes in contact on the frame or the worst case a broken wire. TUNE ECU can help you on the fly I mean when the engine is running to check several sensor values.

    https://g450riders.org/forum/showthr...light=tune+ECU

  9. #6
    badaboum's Avatar
    Points: 578, Level: 11

    Location
    France
    Joined
    Dec 2020
    Online
    2 Weeks Ago
    Posts
    41 / 0 / 0 / 0
    Very similar issue on mine, but it does only do it at the end of a ride. Not at the beginning...

    I'll follow this thread by interest

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •